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 DESCRIPTION  

This is the MoTeC ECU kit allowed for use in the Trans Am TA2 series. It includes a MoTeC M1 ECU with the appropriate 

licensing, a MoTeC Lambda to CAN module, Bosch LSU 4.9 Lambda Sensors, a MoTeC Pro Fuel Pressure Sensor, a MoTeC Pro 

Oil Pressure Sensor, and a M 25-7225 Air Temp Sensor. These pieces are used in conjunction with the TA2 spec chassis 

harness for MoTeC and TA2 spec sensors to control all aspects of the engine. 

 KIT CONTENTS 

• M130 – M130 

▪ Licensed with TA2 Spec Firmware 

▪ Logging Level 2 

• M LTC-D – MoTeC Lambda to CAN Dual 

• M 0258 001 (X2) – Bosch LSU 4.9 Lambda Sensor 

• M KP41 150G – Fuel Pressure Sensor 

• M KP41 150G – Oil Pressure Sensor 

• M 25-7225 – GM Style Air Temperature Sensor 

 COMPONENT LOCATIONS 

The M130 MoTeC ECU and Lambda to CAN (LTC) module will both need to be mounted inside the chassis of the vehicle. They should be 

mounted using vibration isolation on the mounting brackets. Failure to do so could lead to internal damage on the devices. ECUs 

commonly use vibration damping studs and LTCs use hook and loop Velcro. An example of vibration damping studs to use can be found 

here: https://www.mcmaster.com/9232K11/. Place the modules in a way where they will NOT be in direct contact to hot surfaces (ex. Firewall 

Surface). Both modules should be installed in a location with sufficient air circulation and be shielded against thermal emissions from 

surrounding components. 

• The LTC maximum ambient temperature is 100 degrees Celsius (212 degrees Fahrenheit).  

• The M130 ECU maximum operating temperature is 85 degrees Celsius (185 degrees Fahrenheit).  

• Logging can monitor: 

o “Exhaust Lambda Bank 1 Collector Internal Temperature”  

o “Exhaust Lambda Bank 2 Collector Internal Temperature” 

o “ECU Internal Temperature” 

Fuel and oil pressure sensors should not be stressed at any time while in operation. The sensors should be remotely mounted and NOT 

hard mounted in a fixed location i.e. engine/chassis. If this is not done, the sensor could be damaged both internally and externally. The 

sensors should not reach a temperature higher than 125 degrees Celsius (257 degrees Fahrenheit) during operation.  

  

http://www.motecusa.com/TA2/MUSA_TA2_Kit.pdf
https://www.mcmaster.com/9232K11/


 

 
© MoTeC USA Published 22 FEB 2024  Check for latest version at www.motecusa.com/TA2/MUSA_TA2_Kit.pdf 4 

 

RG.KT.0353.01 DATASHEET 

 Bosch LSU 4.9 Mounting Recommendations 
The Lambda sensor should be fitted to the exhaust system with the sensor tip protruding into the exhaust gas flow. The following 

considerations should be considered when fitting the sensor.  

• Place the sensor on an angle between 10 and 90 degrees to the vertical with the tip of the sensor point down to prevent 
condensation build up between the sensor case and the sensor ceramic. 

• Do not place the sensor in a vertical position; excessive heat soak will prevent proper operation. 

• Place the sensor at least 1 metre from the exhaust ports to avoid excessive heat (recommended).  

• Place the sensor at least 1 metre from the open end of the exhaust system to avoid incorrect readings due to outside oxygen 
(recommended).  

o Where necessary for shorter exhaust systems the sensor could be place closer to the engine.  

• Place the sensor away from the flame front coming out of the cylinder head and away from areas where one cylinder may have 
more effect than another.  

Figure 4: Mounting recommendation for Bosch LSU 4.9 sensors 
 

 

 

• If possible do not place near slip joints; some designs allow air to enter resulting in incorrect readings. If the sensor must be placed 
near a slip joint, reverse the slip joints to reduce the influence of introduced air. 

Figure 5: Mounting recommendation for Bosch LSU 4.9 sensors 
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 Connecting Lambda Sensors 
When using the Lambda to CAN module, the legs can be routed out of the vehicle through an additional bulkhead connector or by use of 

grommets through the bulkhead. The module is labelled with A and B corresponding to an A and B leg to plug the sensors into.  

• The Bank 1 sensor that has Cylinder 1 MUST plug into the A leg.  

• The Bank 2 sensor that has Cylinder 2 MUST plug into the B leg. 
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  REQUIRED SOFTWARE 

MoTeC’s M130 ECU will require the most up to date software of M1 Tune to make changes to the ECU. The latest software of 

M1 Tune can be found at the following link: MoTeC M1 Tune 

• The download can also be found by going to https://www.motec.com.au/home, ‘Downloads > Latest Releases > M1 Tune’. 

 

MoTeC’s i2 data analysis software will be needed to analyse the data logs obtained from the M1 ECU. The latest software of i2 

Standard can be found at the following link: MoTeC i2 Standard 

 

• The download can also be found by going to https://www.motec.com.au/home, ‘Downloads > Latest Releases > Data Analysis > i2 

Standard’. 

 

Note: Depending on the ECU being used, Pro Analysis could be enabled. This will determine if the data in the ECU can be opened in i2 

Pro. Additional licensing can be purchased for ECU or computer for opening standard i2 files in i2 Pro. Please contact MoTeC USA for 

further information.  

 

 WEBINARS 

MoTeC has a large list of webinars that are a good resource for beginners in any MoTeC hardware: 

https://www.motec.com.au/webinars-view/webinararchive/ 

A suggested list of webinars to watch for using the ECU in TA2 are below. These webinars are for generic use of MoTeC ECU’s and data 

analysis. Specific TA2 restrictions or topics are not covered. 

M1 Tune - Part 1 

M1 Tune - Part 2 

How to Download the Logging in an M1 ECU   

How to Send an M1 Log via the Internet  

M1 Tune Warning Alarms 

What is the Difference Between i2 Standard and i2 Pro?  

How to Analyse Temperature Data 

Synchronising VCS Video with Data 

i2 Data Analysis: How to Insert Beacons 

i2 Data Analysis: How to Create Overlays 
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  GETTING CONNECTED 

Once M1 Tune has been installed on the user’s computer, the user may connect to the ECU. Make sure that the ECU has adequate power 

before trying to connect to the ECU. Connect the ethernet cable into the main harness of the vehicle and connect this into the computer 

being used. Make sure the IPv4 and IPv6 are enabled on the Ethernet Properties for the given ethernet port on the PC. Open M1 Tune and 

the following should be shown.  

 

• The ECU should be seen by the software in the bottom of the screen shown above. 

• Navigate to ‘File > Open ECU’ or quick key is ‘F8’. This will allow the user to ‘Open’ the ECU and see the package within M1 Tune.  

• The following ‘Access Control’ menu will appear, see picture below. Depending on the user (Guest, Advanced, Tech, Admin), a 

different password/key will be needed to access the package. Once the correct password/key has been entered, the ECU will 

allow the user to see the package and make the allowed changed based on the user’s login conditions. 

 
• Teams can access Guest and Advanced. The Advanced user name password is “Advanced”, same as the user name.  

• You can change users by selecting ‘Tools>Switch Security User’. 
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  SETTING VEHICLE ID 

Setting Vehicle ID in the ECU to the car number allows for identifying what ECU is in a car. This will make it easier to identify an ECU 

associated to a Packages or datalog. 

• Open ECU and login to the Advanced user. 

• Select ‘File>Edit Vehicle ID…’. 

• Set to the car number. 

 ECU THROTTLE CALIBRATION 

Any time the minimum or maximum position of the throttle has changed, the throttle needs to be recalibrated. Not doing so can cause 

the ECU to misunderstand 100 throttle and can cause power loss. There can also be issues with idle control and Engine Overrun (decel fuel 

cut) if the minimum position does not go below 1%. 

 

The Throttle Pedal Position of the car can be calibrated with the following steps: 

• ECU has been opened, ‘File > Open ECU’.  

• Select the ‘TA2’ workbook and select the ‘Throttle Calibration’ worksheet as seen below. 

• Follow the calibration steps shown in ‘Notes’.  

• After Calibration a red bar will show at the top signifying you need to File > Save to commit the changes.  

o This will prompt you to reset the ECU. 
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  APPENDIX 

Specifications 
M130 ECU 

Supply Voltage:   8v – 32v 

Typical no-load supply current:   0.34 amps at 13.8v  

Operating Temp:   -40°C to 85° C 

Size:   107.5 mm x 127.5 mm x 38.7 mm 

Weight:   290 grams 

Mounting:   3 x M5 or 3/16 bolts (vibration isolation recommended) 

CAN Communications:   Design Standard: ISO 11898-2  

                   Message Format: 2.0A (11-bit identifier) 

      Message Layout: MoTeC or AEM (DBC available) 

                  Baud Rate: 500 kbit/sec Default (Selectable)  

                  Internal CAN Termination Resistor: No 

                  CAN Outputs: 1 

 

Figure 1: MoTeC M130 
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 MoTeC Lambda to CAN Module 
Voltage: 11v – 16v 

Current: Up to 4 amps on startup 

CAN communications:  Design Standard: ISO 11898-2  

Message Format: 2.0A (11-bit identifier) 

Message Layout: MoTeC LTC Format 

Baud Rate: 500 kbit/sec 

CAN Termination Resistor: No 

CAN Outputs: 1 

Ambient temp: Up to 100° C 

Size: 38 mm x 26 mm x 14 mm 

Weight: 62 grams 

 

Mounting: 2X 3mm bolts or double-sided Velcro or similar (vibration isolation recommended) 

Harness:  175 mm wire lead 

 

 

 

Figure 2: MoTeC Lambda to CAN Module 
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 150 PSIG MoTeC Pro Fuel and Oil Pressure Sensor 
Voltage: 5 +/- 0.5 vdc 

Current: < 10 mA 

Operating temp: -40°C to 125° C 

Total Error: 0.8% of F.S. Pres 

Proof Pressure: 2X F.S. Pres 

Burst Pressure: 5X F.S. Pres 

Size: 1.94in X 1.45 in X 0.64 in 

 49.5 mm x 36.8 mm x 16.3 mm 

Weight: 70 grams 

Mating Connector:  M 15-7275K 

 

Note: Sensors should be mounted remotely to avoid engine vibration damage 

 Figure 3: MoTeC Pro Pressure Sensor 
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 Wiring 
M130 ECU Pinout
 

C1B ECU M130 
 

   

Pin Size Description  

B1 20 Crank VR+  

B2 20 CAM Sync +  

B3 20 Coolant Temp  

B4 20 Intake Air Temp  

B5 20 Oil Temp  

B6 20 n/c  

B7 20 n/c  

B8 20 Kill Switch  

B9 20 n/c  

B10 20 n/c  

B11 20 n/c  

B12 20 n/c  

B13 20 n/c  

B14 20 n/c  

B15 20 0v A   

B16 20 0v B  

B17 20 CAN 1 HI  

B18 20 CAN 1 LO  

B19 20 n/c  

B20 20 Coolant Pressure  

B21 20 Steering Angle Sensor  

B22 20 Front Brake Pressure  

B23 20 Ethernet TX+  

B24 20 Ethernet Tx -  

B25 20 Ethernet Rx+  

B26 20 Ethernet Rx -  

 

  

C1A ECU M130 
 

   

Pin Size Description  

A1 20 Stepper 2A  

A2 20 5v Vref A  

A3 20 Ignition 1  

A4 20 Ignition 2  

A5 20 Ignition 3  

A6 20 Ignition 4  

A7 20 Ignition 5  

A8 20 Ignition 6  

A9 20 5v Vref B  

A10 20 Ground (-)  

A11 20 Ground (-)  

A12 20 Ignition 7  

A13 20 Ignition 8  

A14 20 TPS AV1  

A15 20 MAP AV2  

A16 20 Fuel Pressure AV3  

A17 20 Oil Pressure AV4  

A18 20 Stepper 1A  

A19 20 Injector 1  

A20 20 Injector 2  

A21 20 Injector 3  

A22 20 Injector 4  

A23 20 Tach Signal Output  

A24 20 Cooling Fan Control  

A25 20 CCP AV5  

A26 20 Battery (+)  

A27 20 Injector 5  

A28 20 Injector 6  

A29 20 Injector 7  

A30 20 Injector 8  

A31 20 Stepper 1B  

A32 20 Stepper 2B  

A33 20 Fuel Pump Control  

A34 20 MIL Light  
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 Auxiliary Connector 
On the TA2 Chassis Harness, Connector 4 (C4) is the Auxiliary or AUX Connector. A mating 6” flying lead AUX (DTM04-12P) is supplied with 

the chassis harness that connects to the ECU. The following will describe each AUX input/output function and how the M130 ECU will 

interact with each signal/output: 

 
 Wire Entry View of Connector 

 

 

 

 

 

 

 

 

 

Power/Grounds: 

Pin 1 (5v Vref) and Pin 2 (0v Sensor GND) are voltage reference for use with sensors. 

Input/Output Functions: 

Pin 3 (Tach): A LOW SIDE OUTPUT that generates a signal for a tachometer to display Engine Speed. Some tachometers require a 

1kΩ pull-up resistor to a +12v source so they can achieve the correct digital voltages. 

 
Pin 4 (Kill Switch): A DIGITAL INPUT that the ECU receives and shuts off fuel and ignition events to kill the engine without power 

cycling the ECU. This input can be wired as a MOMENTARY BUTTON or a TOGGLE SWITCH. This MUST connect to Pin 2 (0v 

Sensor GND) to activate. 

Pin 5 (Fuel Pump Control): A LOW SIDE OUTPUT (Half Bridge) that is used to control a fuel pump relay. This MUST be wired to 

Pin 85.   

Do not wire this pin directly to the fuel pump (-) terminal. 

Parasitic ground feed is possible via this output. Ensure the relay is not powered when the ECU is off. 

Fuel Pump Relay Control Positive should ONLY have 12v+ when the Ignition Switch is ON 

Pin 6 (Cooling Fan): A LOW SIDE OUTPUT that is used to control a cooling fan relay. This MUST be wired to Pin 86 of the relay.  

Pin 7 (MIL Output): A HALF BRIDGE OUTPUT that is used to control an engine malfunction indicator light. The functions of the 

MIL Light can be found in the M1 Tune Trans Am TA2 Firmware Help. This can be configured to go to Battery Positive or 

Negative. 

Parasitic ground feed is possible via this output. Ensure the relay is not powered when the ECU is off. 

C4 AUX 
 

       

Pin Size Description  

1 20 5v Vref  

2 20 0v Sensor GND  

3 20 Tach  

4 20 Kill Switch  

5 20 Fuel Pump Control  

6 20 Cooling Fan Control  

7 20 MIL Output  

8 20 Steering Angle  

9 20 Brake Pressure Front  

10 20 Ignition Switch  

11 20 GND  

12 20 12v+   
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 Pin 8 (Steering Angle) and Pin 9 (Brake Pressure): An ANALOG VOLTAGE INPUT that requires 5v Vref (Pin 1) and 0v Sensor GND 

(Pin 2). Ensure that the correct calibration is setup in the ECU. 

Pin 10 (Ignition Switch): +12v signal input to turn on the Main Relay and power the ECU. 

When this is OFF (not connected to +12v) Half Bridge Outputs can provide parasitic ground. Ensure devices 

connected to these outputs are only powered when the ECU is powered (Ignition Switch connected to +12v) 

Pin 11 (GND) and Pin 12 (12v+): These are for powering low current components that connect to the AUX connector. 

 

Engine and Chassis Grounds 
Grounding is important for the ECU and electrical system to operate properly. Engine performance, sensor readings, and harness integrity 

can all suffer if a minimum grounding below is not followed. 

Minimum size of 2AWG Battery Cable should be used. Optional choice: 2 AWG BATTERY CABLE, BLACK, PER FOOT 

 

Ground Cylinder Head to 

Negative Battery Post 

Ground Engine 

Block to Chassis 

Ground Chassis to 

Negative Battery Post 

http://www.motecusa.com/TA2/MUSA_TA2_Kit.pdf
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 GPS Laps In ECU 
The ECU can receive GPS data over CAN and use it to generate lap timing in the ECU for easier data analysis. The setup is explained in the 

help menus of the ECU Package.  
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 CAN Transmit Functions 
The TA2 Package will allow the user to transmit a fixed set of channels from the M130 to another external device. If the user would like to 

use these channels, the transmit for the CAN Bus must be setup under the ECU. Once the ECU is opened in the M1 Tune software: 

•  navigate to ‘TA2’ workbook and select ‘All Calibrate’ worksheet.  

• The following menu will be opened: 

 
• Select ‘ECU’ shown circled in red. This will open another drop-down menu. 

•  At the bottom of the drop-down menu, there will be two Transmit Tabs: ‘Transmit’ and ‘Transmit AEM’.  

 
• The standard ‘Transmit” will send on the standard MoTeC CAN IDs for a few important channels. 

• Selecting ‘Transmit’ and pressing ‘F1’ will show the help Menu with the general MoTeC CAN messages. 

• ‘Transmit AEM’ are channels being sent from the M130 to emulate what the previous AEM ECU 

• ‘Transmit AEM’ is in place to help aid the ‘Plug n Play’ solution of the M130 with the vehicle and will allow other devices (Logger, 

Dash, etc.) to not have to change CAN Templates for the new M130. These devices will still function correctly with the ‘Transmit 

AEM CAN Bus’ set to ‘CAN Bus 1’. Set to ‘Not in Use’ if you only need the standard MoTeC CAN transmit.  
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 Fuel Tuning 
For fuel tuning below 3000 RPM, there is a table provided (Engine Efficiency Compensation Main) to adjust the main fuel map. This table 

will automatically fade trims to 0.0 from 3000 RPM to 3500 RPM. 

 

Idle Control 
The Idle Ignition Tab in Tune is where you can adjust settings for Idle Control and Idle Aim. Selecting each item in the list will display help 

explaining their function. 
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  CONTACT INFORMATION 

For technical support please use the following information: 

Phone 

704-799-3800  

(M-F, 9AM – 5PM Eastern Time) 

 

Email 

support@motec.com 
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